Drum Pad Beats - Header

The Application Header holds the global application menu actions and controls.

Application Header

App Menu Button

Application Menu Button

Application Menu

User Interface Help

App Help Overlay

The User Interface Help menu item displays an in app overlay that has tappable blue buttons. Tapping a blue button will then display the contextual help describing the item.

App Help PopUp

New Project

The New Project menu item creates a new Empty.dpb file that will need to have Drum and Synth pads filled with content.

New Project From Kit

The New Project From Kit menu item creates a new .dpb file that will have Drum and Synth pads filled with content from the selected Sound Kit. The Sound Kit is chosen from the Sound Kit Browser that holds all current kits installed in the User Library.

Load Recent Project

App Recent Project PopUp

The Load Recent Project menu item loads an existing .dpb file from the Recent Project PopUp.

Load Project

The Load Project menu item loads an existing .dpb file with it's previous pad channels, sound kit and project preferences.

Swap Sound Kit

The Swap Sound Kit menu item displays the Sound Kit Browser for selection of a Sound Kit to fully replace all Drum and Synth pad's audio content.

Save Project As

The Save Project As menu item will save the project as a new .dbp file. The name popup prompt will ask for a new name, by selecting OK without entering text, the new name will automatically auto advance a - number onto the end of the original project file's name.

Export As...

The Export As... menu item will launch a sub menu filled with detailed export actions.

Export Song As wav, ogg, mid

The Export Song As wav, ogg, mid menu item will export the current Song Chain to a .wav, .ogg or .mid file.

Export Song As Zip wav loops

The Export Song As Zip wav loops menu item will export the current Song Chain to .wav loops archived within a .zip file. The loops exported are determined by what Scenes are currently sequenced in the Song Chain.

Export Song As PCMSynth loops and MIDI

The Export Song As PCMSynth loops and MIDI menu item will export all current Scenes in the Song Chain to .wav loops. Once the .wav loops are created, they are mapped inside a Caustic .pcmsynth preset file. A .mid file is then created for the current Song Chain and exported.

A user can then open Caustic and load the .pcmsynth file, import the .mid file into the song sequencer and Caustic will play the Song Chain as it was playing in Drum Pad Beats.

Settings

Opens the Settings dialog for application level settings and preference adjustments.

Exit

The Exit menu item will quit the app after a confirmation dialog is shown.

Main Display

App Main Display

The Main Display displays the current project name and the sequencer's measure : beat : step.

The VU Meter displays the master's signal.

Metronome ToggleButton

App Metronome

The Metronome ToggleButton enables/disables the metronome click when the sequencer is playing.

Play/Stop ToggleButton

App Play Button

The Play/Stop ToggleButton starts and stops the pattern and song sequencer.

Record ToggleButton

App Record Button

The Record ToggleButton enables/disables the Overdub or Real-time sequencer recording.

Overdub Recording

Overdub Recording is pattern mode recording where when in Pad Mode, the sequencer records the pad taps into the selected pad's step sequencer.

Real-Time Recording

Real-Time Recording is pattern mode recording where all live Scene switching is recorded for final export. During this mode pad tapping is recorded to the output stream and the triggers are not placed in the step sequencer.

App Record Button

The Breadcrumb Display shows the selected Scene, selected Drum or Synth bank, selected Pattern and the selected Pad/

Save Button

App Save Button

The Save Button will save the current state of the application to the .dpb file.

Logo Button

App Logo Button

The Logo Button displays an application popup showing the version and help links.